WordPressバージョンアップメモ 4.5.2⇒4.7.2 メモリ不足エラー、500エラー

未分類

4.7.0, 4.7.1 の脆弱性の報告を受けてバージョンアップの依頼を受け
4.5.2で動いているサイトを4.7.2へのバージョンアップを試みた。

いつものようにファイルとDBをバックアップ後、管理画面からアップデートを試みたが、
管理画面側は正常に動くもののフロント側にメモリ不足のエラーと500エラーが出た。

問題の切り分けのため、プラグインを外したり 一旦 4.6.1 を入れてみたり試した結果、
プラグインの Bogo が影響していることが分かった。

Bogo のサイトでバージョン確認すると 3.1.1 が公開されていたためインストールされていた
2.7 からのバージョンアップさせたところエラーはなくなった。

ただ、同プラグインで実現していた英語ページが全て 404 エラーになってしまった。。。
こちらは、パーマリンクの再構築をすることで解決。

ここまでで一先ず WordPress 4.7.2 へのコアバージョンアップが完了した。

タイトルとURLをコピーしました